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Purpose 
 
This guide is intended to assist in the initial installation and proactive maintenance of your 
installation of the RightNow 7.x application.  Adherence to the guidelines laid out in this 
document will help to ensure optimal performance and stability of your RightNow 
deployment. 
 
Product architecture, network requirements, workstations configuration requirements, 
installation methodologies, network maintenance, and workstation troubleshooting are each 
covered herein.  Please see our knowledge base at http://rightnow.custhelp.com for updates 
in each of these areas.  
 
 
 
RightNow Architecture 
 
The RightNow application utilizes a standard 3-Tier architecture consisting of the following: 
 
Client Tier: The client tier consists of a web browser that presents content received from the 
application tier. The client tier communicates with the application tier through the Internet 
via Hypertext Transfer Protocol (HTTP) or Hypertext Transfer Protocol with Secure Socket 
Layer (HTTPS). 
 
Application Tier: The application tier provides the logic for the RightNow product and 
communicates data from the database tier to the client tier. This tier resides on a web server. 
 
Database Tier: At the base of an application is the database tier, consisting of the database 
management system that manages the database containing the data users create, delete, 
modify, and query. 
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Networking Requirements and Recommendations 
 
As the RightNow application is web-based, the corporate network plays an important role in 
the efficient and consistent connectivity to the application. The following items should be 
considered when implementing the RightNow solution: 
 
 
Bandwidth: For satisfactory performance, a high-speed Internet connection is required. Dial-
up connections are not supported. The information below provides guidelines for the network 
bandwidth to the Internet. 
 
As a recommended minimum, 25kbps (kilobits per second) must be dedicated per concurrent 
logged in agent. For example, if there are 20 agents logged in, a minimum of 500kbps of 
dedicated WAN / Internet bandwidth should be available for the RightNow application.  
 
As an example, based on the above recommendation, a T1 line will support approximately 60 
concurrent agents, depending upon the particular implementation & the usage patterns of the 
agents in question.  Regular bandwidth utilization monitoring should be done in production 
environments to facilitate the tuning of the amount of bandwidth provisioned and its optimal 
utilization. 
 
If your network utilizes a private WAN (typically over multiple call centers) specified 
bandwidth must be available throughout the entire network path; that is from the Internet to 
the Private WAN to the LAN and to the Agent workstation. 
 
 
Response Test Time:  Your network connectivity to the RightNow data center (either 
Internet or private WAN) should provide less than a 300ms response time test (RTT) and less 
than 1% packet-loss. Where possible, your IT/IS staff should work to minimize WAN / 
Internet latency to ensure proper application performance. 
 
 
Network Appliances (including Proxy Devices, Firewalls, and Content Filters):   
The customer network administration team must ensure that all communication between the 
RightNow client application and the RightNow hosted server is allowed, in an unrestricted 
manner, through all levels of the customer network.  All network appliances must be 
configured to allow all traffic between the client workstations and the following domains to 
occur in an unrestricted manner: 
 

*.custhelp.com 
*.rightnowtech.com 
activex.microsoft.com 
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Applicable network appliances include the following (but are not limited to): 
 

Gateways 
Routers 
Hubs 
Bridges 
Switches 
Proxy Servers 
Firewalls 
Load Balancers 

 
Proxy servers must be configured with authentication and caching exclusion rules for each of 
the domains listed above. 
 
Firewalls must be configured to allow traffic on HTTP port 80 and HTTPS port 443 for the 
domains listed above. 
 
 
Customers using HTTP / IP proxy devices, either directly or indirectly, must ensure that 
these devices are configured correctly for optimal performance by the RightNow application. 
These devices include but are not limited to:  
 

• Traditional proxy server (PC server or dedicated appliances),  
• Content caching/acceleration devices,  
• Local content filtering/inspection appliances, and  
• Hosted content filtering and inspection services.  

 
 
Quality of Service (QoS) Packet-Shaping Policies: If your networks have QoS / packet-
shaping policies implemented, the RightNow application should be considered a 
performance-sensitive application and accordingly given appropriate priority to ensure 
maximum performance.  
 
If your organization has not instituted QoS/packet-shaping policies, you should consider the 
economic advantages of grooming network traffic to provide priority applications, such as 
your RightNow application, sufficient access to network resources. Whenever possible, 
customer LAN / WAN connectivity should be groomed to match generally-accepted VOIP 
standards:  
 

• Less than 250ms response time test (RTT),  
• Less than 5% latency jitter,  
• Near-zero packet-loss, and  
• Appropriate / consistent Layer-2/3 QoS policing. 
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Wide Area Network / Internet Load Balancing 
 
Wide area network (WAN) and internet load balancing must be performed in a per-session 
vs. a per-packet manner for RightNow traffic.  Per-packet load balancing often leads to out of 
order packet delivery which will result degraded performance of your RightNow application 
and may result in its decreased stability. 
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Workstation Requirements and Recommendations 
 
As the RightNow application utilizes a basic web browser residing on an agent workstation, 
the following items are recommended to maximize application performance.  Workstation 
specifications can also be found in answer ID 31 at http://rightnow.custhelp.com, along with 
server requirements for non-hosted customers. 
 
Hardware Configuration: The minimum hardware recommendations for the staff member 
workstation listed in Table 1 are for RightNow applications. These recommendations do not 
include the additional disk space required for operating system swap space (refer to the 
operating system documentation) or other applications running on the workstation. 
 

Table 1: Minimum Workstation Hardware Recommendations 
 

RightNow 
CRM Version 

Workstation 
Type 

Memory CPU Hard Disk 

Agent 512 MB Minimum: 400 MHz 
Recommended: 700 
MHz or greater 

50 MB free with 512 
MB virtual memory 

7.0.x 

Administrator 512 MB 1 GHz 50 MB free with 512 
MB virtual memory 

Agent Min: 512 MB 
Recommended: 1 GB 
(7.5.1 and up) 

Minimum: 700 MHz 
Recommended:  
 - 1 GHz (7.5.0) 
 - 1.5 GHz (7.5.1 and 
up) 

50 MB free with 512 
MB virtual memory 

7.5.x 

Administrator Min: 512 MB 
Recommended: 1 GB 
(7.5.1 and up) 

1.5 GHz 50 MB free with 512 
MB virtual memory 

*Required free hard drive space will vary depending on database size and file attachments. 
 
Operating Systems: RightNow staff member and end-user functions are best performed on 
workstations running the following operating systems. Operating systems that aren’t listed 
for a corresponding release in table 2 are not supported. 
 

Table 2: Supported Operating Systems 
 

RightNow CRM Version Supported Operating Systems 
7.0.x Windows 2000 Professional 

Windows XP Professional 
7.5.x Windows 2000 Professional (SP 4) 

Windows XP Professional (SP 2) 
Windows 2003 Server* (7.5.4 and up only) 

* If you are running Windows 2003 Server, Enhanced Security Mode cannot be 
enabled in Internet Explorer. 
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Workstation Display Settings: To view RightNow windows, consoles, and panels, you 
must configure the display properties of your workstation to display a minimum screen area 
of 1024 by 768 pixels with the “small fonts” or “normal size” (96 dpi). 
 
.NET Framework: RightNow staff and administrator workstations require and must support 
.NET Framework Version 1.1. RightNow CRM Version 7.0.0 requires this only for staff 
members using the campaign console, sales quotes, or computer telephony integration. 
RightNow CRM Versions 7.5.1 and up require Service Pack 1 for .NET Framework 1.1.  
 
Web Browsers: RightNow CRM requires a PC version of Microsoft Internet Explorer for all 
agent/admin activities. Table 3 shows Internet Explorer version requirements. For end-user 
web browser recommendations, refer to Answer ID 31 at http://rightnow.custhelp.com.  
 

Table 3: Internet Explorer Version Requirements 
 

RightNow CRM  
Version 

Internet Explorer 
Version 

7.0.x 
7.5.0 – 7.5.5 

6.0 (SP1 or newer) 

7.5.6 6.0 (SP 1 or 
newer) or 7.0 

 
Additional Requirements: If you are using RightNow Live or RightNow Sales, refer to 
Table 5 for software and hardware requirements. These requirements are in addition to the 
workstation recommendations listed above. 
 

Table 5: Additional Requirements 
 

RightNow CRM 
Version 

User Additional Requirements 

RightNow Live Agent Java browser plug-in Version 1.4.1_06 
Sales Quotes Staff Member Microsoft Word 2000 or newer (merging 

quotes only) 

7.0.x 

Disconnected Access Staff 
Member 

- Apache 2.0 
- Minimum of 200 MB free hard disk space. 

RightNow Live Agent Java browser plug-in Version 1.5.0_02 
Sales Quotes Staff Member Microsoft Word 2000 or newer (merging 

quotes only) 

7.5.x 

Disconnected Access Staff 
Member 

- Apache 2.0 
- Minimum of 200 MB free hard disk space. 
(CRM 7.5.0) 
- Minimum of 500 MB free hard disk space 
(CRM 7.5.1 and up) 
- Minimum 1.5 GHz processor (CRM 7.5.1 and 
up) 
- High-speed Internet connection for 
synchronizing (CRM 7.5.1 and up) 
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 Workstation Settings: Not all of these settings will appear for Windows 2000 workstations. 
Additionally, several settings are marked for troubleshooting only. 
 

1. (Required) Verify current user is member of workstation Administrators Group: Start 
> Control Panel > Administrative Tools > Computer Management > System Tools > 
Local Users and  Groups > Groups > Administrators 
 
o Verify the current Windows profile is listed under the Administrators group.  
 

2. Verify Browser Encoding Settings:  Internet Explorer > View > Encoding 
 
o Auto-select – Not selected 
o Western European ISO – Selected 

 
3. Verify correct browser caching: Start > Control Panel > Internet Options > General 

Tab > Settings Button 
 
o Check for newer versions of stored pages – Every visit to the page 
o Amount of disk space to use – Greater than 1000 MB 

 
4. Verify Browser Security Settings: Start > Control Panel > Internet Options > Security 

Tab > Internet (Globe Icon) Selected > Custom Level Button 
 
o .Net Reliant Framework 

 Run components not signed with Authenticode – Prompt 
 (Required) Run components signed with Authenticode – Enable 

 
o ActiveX controls and plug-ins 

 Run Automatic Prompting for ActiveX controls - Enable 
 Binary and script behaviors – Enable 
 (Required) Download signed ActiveX controls – Prompt or Enable 
 (Required) Run ActiveX controls and plug-ins – Enable or Prompt 
 (Required) Script ActiveX controls marked as safe for scripting – Enable or 

Prompt 
 

o Downloads 
 File Download – Enable 

 
o Miscellaneous 

 Access data sources across domains – Prompt or Enable 
 Allow scripting of Internet Explorer web browser control – Enable 
 Allow script-initiated windows without size or position constraints – Enable 
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 Allow Web pages to use restricted protocols for active content – Enable or 
Prompt 

 Display mixed content – Enable or Prompt 
 Launching of programs and files in an IFRAME – Enable or Prompt 
 Navigate sub-frames across different domains – Enable or Prompt 
 Userdata persistence – Enable 
 Web sites in less privileged web content zone can navigate into this zone – 

Enable or Prompt 
 

o Scripting 
 (Required) Active Scripting – Enable or Prompt 
 Allow paste operations via script – Enable 
 Scripting of Java Applets – Enable 

 
5. Verify Advanced Browser Settings: Start > Control Panel > Internet Options > 

Advanced Tab 
 
o Browsing 

 Always send URLs as UTF-8 – Unchecked 
 Enable third-party browser extensions – Checked 
 Disable Script Debugging (IE) – Unchecked (when troubleshooting) 
 Display notification about every script error – Checked (when 

troubleshooting) 
 

o HTTP 1.1 Settings 
 Use HTTP 1.1 through proxy connections – Checked 

 
o Java (Sun) 

 Use Java 2 v 1.4.1_x for applet – Checked 
 

o Security 
 Allow active content to run in files on my computer – Checked 
 Do not save encrypted pages to disk – Unchecked 
 Empty Temporary Internet Files when browser is closed – Unchecked 
 Use SSL 3.0 – Checked (for sites using SSL) 
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6. Verify .NET Permissions: Start > Control Panel > Administrative Tools > Microsoft 
.NET Framework 1.1 Configuration > Configure Code Access Security Policy > 
Adjust Zone Security > Make Changes for Current User 
 
o My Computer – Full Trust 
o Local Intranet – Medium Trust or Higher. 
o Internet – Medium Trust 
 

7. When your workstation is not set up to use a proxy server, please uncheck the 
following checkbox:  

 
Internet Explorer > Tools > Options > Connections > LAN Settings > 
Automatic Configurations   

 
Automatically detect settings  (Checked by default) 
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Installation Methodologies 
 
Web-based Installation: To use the most common installation methodology, an agent with 
workstation administrative rights simply navigates to the appropriate URL, for example: 
  
 http://interface.custhelp.com/cgi-bin/database.cfg/php/admin/launch.php
 
After navigating to the login page, and entering an agent username and password, the 
RightNow Component Manager begins to download the required components onto the 
workstation. 
 
The Component Manager installs the files via the following process: 
 
1. The installation directory for component files, executable files, and dictionary files is 

determined. This is typically a subdirectory under the “RNT” directory, located in each 
Windows user profile (e.g. C:\\Documents and Settings\<username>\RNT\<sitename>). 
 

2. The installation directory is checked for the ComponentManager.RNTmodule file. If 
the timestamp of the currently installed file does not match the timestamp of the most 
current version of the file, the ComponentManager.RNTmodule file is queued for 
downloading, and is downloaded. If a download occurs, the 
ComponentManager.RNTModule is restarted. 
 

3. The timestamps of the components are compared to the timestamps of the most recent 
files. If these timestamps differ, the current versions of the files are added to an action 
queue for downloading. 
 

4. If any controls have been queued, clearing of the browser cache and behavior files are 
queued. 
 

5. The action queue is processed. This causes all queued files to be downloaded into the 
installation directory. It also causes the browser cache to be cleared of all RightNow 
HTML component behavior files. 
 

6. Downloaded component files are registered using DLLRegSvr. Information regarding 
file registration is located. 
 

7. All HTML component behavior files are downloaded and placed into the browser cache. 
 

8. A new entry in the ComponentManager.log file is started. 
 

9. Every component in the “RNT” directory that was just downloaded is unregistered and 
reregistered with Windows. 
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Stand-Alone Installation: For restricted environments, companies running version 7.5 or 
newer of the RightNow application can implement the Stand-Alone Component Installer 
through the following process: 
 

Step 1: Log into Windows with a profile that is a member of the local Administrators 
group. 
 
Step 2: Log into RightNow with the “administrator” account. 
 
Step 3: Download the Stand-Alone Component Installer by navigating to the Links menu, 
and selecting the “Download Standalone Component Installer” option. 
 
Step 4: Unzip the downloaded file into the desired directory. 
 
Step 5: Double-click Setup.exe, and follow the installation instructions. 

 
Note: Installation via this method prevents automatic updates to the workstation via the 
Internet. 
 
 
The Stand-Alone Component Installer can also be used to distribute the RightNow 
components via the local network. This can be done by mapping a shared network drive 
containing the components, and running Setup.exe. Additional methodologies include 
pushing the files to the workstations via SMS, and executing Setup.exe. Please consult with 
your IT staff on corporate application installation procedures. 
 
Note: Regardless of the method used, the Setup.exe file must be executed as a user that is a 
member of the local workstation Administrators group. 

 
The Stand-Alone Component Installer installs components via the standard Microsoft 
Installer (MSI) process, and activates the RightNow Component Manager to execute the 
steps listed in the web-based component installation process. 
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Network Troubleshooting 
 
Your networks should be proactively monitored to avoid false-positive reports of application 
issues. Even if your IT / IS staff are in another location, your staff should evaluate and check 
the state of corporate LAN/WAN/Internet connectivity before submitting incidents to 
RightNow's Technical Support team. This helps to ensure accuracy and efficiency when 
troubleshooting your issue. 
 
When requesting network troubleshooting assistance, please note the following guidelines: 
 
WAN / Internet Performance Information You or your IT/IS staff should generally be 
able to provide appropriate WAN / Internet troubleshooting and performance information. 
This includes information such as:  
 

• ICMP/UDP traceroute information from the affected call center to the associated 
RNT datacenter,  
 

• greater than 1000-byte and greater than 1000-byte ICMP echo (ping) information 
from the affected call center to the associated RNT datacenter, and/or other more 
specific IP and Layer-4 session information related to reported issues. 
 

 
Network Topology: You should be able to provide a description of your network topology, 
such as single network, multi-site network with no connectivity, multi-site network with 
public [VPN] connectivity, multi-site network with private/dedicated connectivity. This 
description should include but not be limited to the following:  

• ISP(s),  
• circuit/access types (for both public and private network segments),  
• routing equipment vendor to ascertain configuration capabilities,  
• LAN/WAN utilization stats. Charts are preferred but the minimum, average, and 

maximum values for each circuit and location are acceptable statistics.  
• network appliances related to connectivity, such as firewalls, proxies, content filters, 

plus their configurations. 
 

Performance Monitoring Statistics: Basic LAN / WAN performance monitoring statistics 
should be available to analyze per site and per workstation issues. In addition, raw logs that 
provide information such as packet capture and network interface stats should also be 
available. Open source and multi-platform packages such as MRTG are inexpensive and easy 
to implement. 
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Workstation Troubleshooting 
 
When requesting workstation troubleshooting assistance, please note the following 
guidelines: 
 
Agent PC Configurations: You or your IT/IS staff should be prepared to discuss the state of 
agent PCs, including system components and resource utilization with tools such as 
Microsoft Perfmon. You should also be prepared to isolate individual agent workstations and 
network interfaces for comparison purposes in the event sporadic application performance 
conditions are present. 
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Appendix A 
 
Answer ID: 2091 on http://rightnow.custhelp.com 
 
  Why do files from RightNow download more than once? 

  
  Question 

  
Why do files from RightNow download more than once? Sometimes when we log in, 
the Component Manager downloads more files, even though we are still on the same 
version of RightNow. Why? 
  

  Answer 

 

  

The RightNow Component Installer controls the downloading of the RightNow 
components by comparing the files located on the workstation with the creation date 
and time of the files located on the RightNow servers (for hosted sites) or the 
download server (for non-hosted sites). If the files do not exist on the local 
workstation, or if the files on the workstation have an earlier creation date than the 
server files, the new files are loaded. Several situations can cause a download of the 
files:  

 The temporary Internet cache is cleared on the local workstation. This causes the 
HTML component behavior files (*.htc files) to be re-downloaded to the temporary 
Internet cache.  

 User profiles are cleared from the local workstation by IT security policy after the 
user logs off the workstation. This causes all user specific files to re-download.  

 Updated files are placed on the download server. If newer files are available, you 
will download those specific files the next time you log in.  

If you find that you download files every time you log in, verify that you are not 
clearing the temporary Internet file each time you close the browser. From your 
Internet Explorer browser window, select Tools > Internet Options and click on the 
Advanced tab. In the Security section, make sure that the option for Empty Temporary 
Internet Files folder when browser is closed box is NOT checked.  

In addition, you may need to increase the file cache for your machine. From your 
machine's desktop, right click on My Computer and select Properties > Advanced tab 
> Performance Options > Change. You can modify the paging file size for selected 
drive section. Click Set and OK. Click OK on the remaining pop-ups.   
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Appendix B 
 
Answer ID: 2135 on http://rightnow.custhelp.com 
 
Question 
When an agent logs in for the first time, is there a specific file that is updated that we 
could allow the agents to have access? Our agent workstations are locked down pretty 
extensively and we'd like a better understanding of where the file download will write. 
 
Answer 
In versions 6.0.2 and higher, the RightNow application includes a helpful feature called 
the Component Manager. The Component Manager runs automatically whenever a staff 
member logs in to a site. It detects whether you have the correct ActiveX controls for 
the site you are entering. If not, it installs or upgrades all of your ActiveX files for that 
site automatically. 

Version 7.5: RightNow version 7.5 includes a dynamically-generated component 
installer. This feature is available to staff members whose profile has the Administrative 
Settings option enabled (from the Administration tab). To download the installer, log in 
to the administrative console of your RightNow application. Click the Links icon on the 
far right side of the navigation bar and select Download Standalone Component 
Installer.  

The link generates and downloads a .zip file. To run the component installer, unzip the 
file to the desired location, and double-click the setup.exe file. This installs a link to 
RightNow on the machine's desktop. To run the setup.exe file, you must have full admin 
rights on the workstation. Once the link to the RightNow application is installed on the 
desktop, the user does not require administrative rights to use the link to the RightNow 
application.  

Note: In some builds of 7.5, the Download Standalone Component Installer option does 
not appear in the Links menu if you have custom links defined in the TBAR_LINK_LIST 
configuration setting. If this is the case with your site, temporarily remove the custom 
links from the TBAR_LINK_LIST setting and have the user log in again to the RightNow 
application to access the standalone component installer. You can then, re-edit the 
TBAR_LINK_LIST setting to add the links to the menu. 

Versions 6.0 and 7.0: In versions 6.0 and 7.x, all RightNow components downloaded 
onto the local workstation must be registered by an administrative user. After this initial 
registration, all users regardless of workstation privileges are able to login to download 
and install future component updates for the version of software they are using, 
including upgraded dot releases. There are three basic methods for the registration 
process:  

1. Navigate to the support login page as a user with administrative privileges to the 
local workstation. This registers the ActiveX control for RightNow Service as an 
administrator, and in turn properly registers the RightNow Service components.  
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2. Run Internet Explorer as an administrator on the local workstation. This can be 
done by right-clicking on the Internet Explorer executable file, and selecting “Run 
As” (if available). This registers the ActiveX control for RightNow Service as an 
administrator, and in turn properly registers the RightNow Service components.  

3. Using System Management Server (SMS) or similar method, you can push the 
RightNow ActiveX control (RNTProcMan.ocx) and Component Installer 
(RNTCompInst.exe) to a local workstation. 
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Appendix C 
 
Answer ID: 2412 
 
What is the Workstation and Network Data Collector (rntinfo.bat 
file)? 
 
Question 
Our support agent wants us to run the Workstation and Network Data Collector 
(rntinfo.bat file) on some work stations to trouble shoot our support issue. 
 
What does this file do and why is it necessary? 
 
Answer 
The Workstation and Network Data Collector is a .bat file that can be run on a work 
station to collect pertinent system and performance information. This information is 
written to a text file so that our RightNow support agents can review and evaluate the 
following: 

• Workstation information -- including memory and disk space  
• Network connectivity -- traceroute information with loaded packets  
• Component Manager Log file -- list of RNT components that have been 

downloaded to the machine  

If you have reported performance issues related to your RightNow application, your 
Support Account Manager may request that you run the data collector .bat file and 
attach the resulting .txt file to the incident.  

To run the RNT_Info.bat file, use the steps below. Typically, when the file runs, it will 
take 3-4 minutes for the file to run. Upon completion, the window will close 
automatically and a new text file named rntinfo is saved to your desktop.  

1. Click on the file attachment, found in the referenced answer, named rntinfo.bat.  
2. At the prompt to Open or Save the file, click Save.  
3. Save the file to your desktop. When you get the Download Complete message, 

click Close.  
4. From the desktop, double click the file or right click and select Open.  
5. At the prompt, enter the site name and press Enter. This is the name of the 

database for your application.  
6. At the next prompt, enter the interface name and press Enter.  
7. While the check is performed, text will scroll in the window and then periodically 

pause. Leave the window running; it will close automatically upon completion.  
8. When complete, a file named rntinfo.txt will be saved to your desktop.  
9. Attach the rntinfo.txt file to your incident and update the incident. 
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